How to Troubleshoot ERR_HTTP2_Inadequate_Transport_Security Problem in Google Chrome

This article explains how to fix ERR HTTP2 Inadequate Transport Security error in Google Chrome. Many users have encountered this error message when connecting to the CA server via HTTPS in the Google Chrome browser. It happens because of certain security settings.

CyberArk Free Tools - 2. PAS Report...
CyberArk Free Tools - 2. PAS Reporter Overview

Before talking about solutions, it’s worth identifying the causes and scenarios that can cause this error in Chrome.

What causes the ERR_HTTP2_Inadequate_Transport_Security error?

  • Outdated version of Chrome: In most documented cases, it can be assumed that this problem is caused by a scenario where you are using an outdated version of Chrome that lacks the necessary security mechanisms to facilitate connection to the CA.
  • Disruptive browser cookies: It has been found that some Chrome cookies may be responsible for this behavior when attempting to connect to the CA server via HTTPS.
  • Windows Server uses weak ciphers: It turns out that a common cause of this error message in Google Chrome is that your Windows Server installation uses weak ciphers.

How can I fix the ERR_HTTP2_Inadequate_Transport_Security error?

=&0=&